Everything was great until it wasn't <running parts now>

All things related to Centroid Oak, Allin1DC, MPU11 and Legacy products

Moderator: cnckeith

SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

While I agree the motor started off looking bad, the coolant had only entered into the first chamber with the connections. It the second chamber had the tachometer and that was clean. The third chamber is the motor itself. As detailed above, I traced the low resistance to the brush holders, removed them, cleaned them, cleaned the motor housing, painted the outer motor housing (because the chemicals that I used to clean the housing took off the paint), reinstalled the brush holders and checked the resistance to ground.

After all the clean up I got infinite ohms from each of the brush holders to ground on my Fluke 87 meter. Not a cheap meter. After installing the brushes, rotor and getting the motor buttoned up. I got the following resistance readings:

Motor Red to Black Black to Green Red to Green

X 2.7ohms 25Mohms 24Mohms
Y 2.4 Infinite Infinite
Z 2.3 Infinite Infinite

So all readings were within what would be considered good.

I sure as heck don't want to blow the control board again, but I don't see why this won't work and why I need a new motor. If you make a case for why I need a new motor, I am listening. We don't need problems, either with start up or down the road.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

We got the machine started up and all three axis moving properly. We do notice that on the X motor we get a rougher Vabs graph compared to the Y and Z motors. This could be because of the motor itself, tuning or the mechanical system. We are going to swap the X and Z motors to determine if it is the motor. If it is, then we will buy a new motor. By swapping motors and seeing if the problem follows, we will have definite evidence that the motor needs to be replaced.

I will post again when we swap motors, but it might be a couple of weeks since we have a few other things we need to attend to for now. We may not run this machine at all or very little during that time.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

With the motor swap complete, we ran the Vabs on all three motors and the suspect motor that we moved to the Z-axis is a bit rough. While we got the system back together, we will move it and see how it goes. But we know that this motor for whatever reason delivers a rougher Vabs graph.

I assume that the Vabs is a measure of the voltage required to move the motor. A smoother graph would mean that the motor is following the inputs closely, I would assume then that a rougher graph would mean that the motor is not following as closely and the voltage will surge up until the motor moves and then the voltage goes down and then builds up more voltage again and then making the move and repeating this cycle over and over.

Is that correct thinking or is there something else that the Vabs is showing us?

Since the brush holders have come out of the motor housing and the brushes need to break into the contour of the commutator, could this be a factor or the cause of this rougher Vabs graph? We will tune the drive and monitor this to see if it changes over some use.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

Vabs = Velocity absolute.

We went to tune the motors and we had another failure. This time it was the Y axis. This is getting frustrating. The culprit is supposed to be the "bad" motor, however, this bad" motor is on the Z-Axis and the Y-Axis blew. When this "bad" motor was on the X-Axis, it was the Z-Axis that blew a transistor. It doesn't make a lot of sense that the "bad" motor was a contributor since it was not moving at the time. There are only two explanations that I can come up with:
1. the transistor was marginal from the first incident
2. there is some other issue causing these failures

All axis move smoothly and have no mechanical issues. We rechecked this before commissioning the system. We are being cautious because we don't want any more problems, so we checking before powering. Please keep in mind that the "bad" motor has resistances that are inline with what is expected as posted above.

Part of my frustration is that this system worked for 25 years, which had to include several years in the "bad" condition with no problems with an Analam control. And I know the old Analam control might not have been as sensitive as the new Centroid driver is. And we have had 3 weeks or so of good performance and producing parts with the bad motor before we had a blown transistor on the driver that was not associated with the "bad" motor.

I am not going to spend $1400 or more for a new motor without some assurance that the problems would go away.

If the problem is indeed the motor then why is the driver responsible for controlling this bad motor not blowing?

Any thought or direction would be appreciated. Thanks. We are looking forward to getting past this issue and making parts again. When this was working it was awesome.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

ImageHere is a copy of the electrical Schematic. We used the Bridge rectifier/capacitor/resistor power supply from the Analam control. It worked for 24 years (it was built in 1999). We are also using the contactor from the Analam with a 115VAC coil. We don't have 24VAC in the cabinet and 115v works for this relay.
Fryer Centroid CNC rev A combined.pdf
(238.49 KiB) Downloaded 9 times


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

Q5, Q6, Q7 and Q8 are shorted. This is the Y-axis.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

We used the original cabinet from the Analam control. It is tight but the Allin1 it all fits in there. On the bottom is a pair of 3.5" (I think that is the size) muffin fans with an automotive paper air intake filter. I tried to match it up but so far haven't found a match yet. We have some round filler plugs that we purchased from Automation Direct to fill the two holes that we are not usnv with the new Centroid control.
IMG_4042.JPG
IMG_4043.JPG
These pictures should be rotated 90 degrees clockwise to be in the correct orientation. I can't seem to straighten it out here.

The power supply/rectifier-capacitor is the same one that was used for the Analam. We used the Centroid idea of mounting the bridge rectifier on top of the capacitor. We used bare FR4 rather than making a circuit board. We also machined small fins into the back side of the bridge rectifier heat sink.
We also used the original big ceramic resistor that came with the Analam.

We are getting 167 vdc out of the rectifier/smoothing capacitor.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

Fryer MB-14 Bed Mill
IMG_5076.JPG
We have Y drive belt cover off to fix an issue with play in the handwheel. We need to get everything ready to run.

The Z-motor is way up top just to the left of the clock and above the monitor. The Fryer is a Made in the USA machine that has been solid for us before the change over to Centroid. Once past these problems, we see lots of parts and years of service ahead.


eng199
Posts: 396
Joined: Fri Jan 10, 2014 11:29 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: Yes
CNC Control System Serial Number: none
DC3IOB: Yes
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
Location: Howard, PA

Re: Everything was great until it wasn't

Post by eng199 »

Did the previous control have a transformer? The motors indicate 140V maximum, but you have 165VDC bus. This system should have a step down transformer to get 100-120 DC bus for best longevity.

Did you rotate the motor with pins shorted as per http://192.168.0.238/tech_bulletin/uploads/155.pdf? This is a good way to check for shorted windings that are easily missed with an ohm meter.

Do the motor cables flex at any point? Flex points are the first place the cables will break or short. If the cables are 20+ years old, it wouldn't be unusual for the insulation to break down whether flexed or not.

Do any of the axes ever have large oscillations? Some handwheels similar to the ones in the picture are heavy and act like flywheels. If they are turning with the motor, motion control can be poor.


SlicedBread
Posts: 22
Joined: Thu May 25, 2023 4:07 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: Yes
Oak CNC controller: No
CNC Control System Serial Number: 2880
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
Location: Long Island, NY

Re: Everything was great until it wasn't

Post by SlicedBread »

I was having some problems with the multi-meter last time and traced the problem to the probes although the problem with the machine remains the same. The readings below are measured from the cabinet and therefore have different colors noted than the previous check that was done at the motor.

X Motor
BLU to VLT 2.4 ohms
VLT to GND Infinite
BLU to GND Infinite

Y Motor (the output that failed)
BLU to VLT 2.3 ohms
VLT to GND Infinite
BLU to GND Infinite

Z Motor
BLU to VLT 2.2 ohms
VLT to GND 28 M ohms
BLU to GND 29 M ohms

Base resistance on Meter/probes: 0.2 ohms
Meter: Fluke 179


Post Reply