Page 7 of 9

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sat Mar 30, 2024 8:55 pm
by glbreil
Well it was a pretty productive day. Besides getting the start up issue resolved I was able to get the Leadshine Servo Tuning done with everything in the machine. Pretty exciting to see some things moving after a lot of work.

Couldn't get the videos from my iPhone to work here so I added them to the Google Album.

https://photos.app.goo.gl/KL88FycMxDj5WmwWA

Gary

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sat Mar 30, 2024 10:08 pm
by lavrgs
Does your CNC12 software start on boot up of your computer?. In may case the sequence doesn't matter if the computer is running before the ALLIN1DC is powered up but I manually run the software.If I start before the ALLIN1DC is ready I will get a similar error. Essentially telling me the board isn't ready.

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sat Mar 30, 2024 10:30 pm
by glbreil
No I am starting CNC12 manually after the computer boots up. This is the only sequence that works:
1. Power Up Machine and Drives.
2. Power on the computer.
3. Power Up the Hickory Board.
4. Start CNC12

It works every time. Move #3 up to #2 and it never works. CNC12 either stops completely on the initializing MPU screen or it sits on that screen until timeout and it closes CNC12.

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sun Mar 31, 2024 12:46 am
by cncsnw
If you:
1) Power up the Hickory board
2) Power up the computer
3) Run these three commands in a command prompt window:
a) ipconfig
b) ping 10.168.41.1
c) ping 10.168.41.2
... what results do you get?

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sun Mar 31, 2024 10:05 am
by glbreil
Marc, I powered up as stated above and successfully pinged both IP addresses. Then I opened CNC12 and it timed out while initiating MPU.

I restarted the way I described before and it all opened and connected successfully.

Gary

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Sun Mar 31, 2024 4:14 pm
by cncsnw
It sounds like you need to get Centroid tech support involved. Perhaps the BBG boot code needs another look.

It should always be possible to start up a control by powering on all logic power simultaneously, so that the drives have logic power; the Hickory starts booting; and the PC starts booting. This is how an industrial installation is going to be run every day.

It is generally expected that the PC is going to take longer to boot than the Hickory (or MPU11 or Oak or Allin1DC), so that latter device should be ready to talk by the time Windows launches CNC12. The "ping" commands in start.bat were originally added not just as diagnostics (though they are very useful for that) but also to kill a little extra time in case the PC booted up too quickly.

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Mon Apr 01, 2024 8:49 am
by eng199
If you still get "MPU requested resend" in your msg_log.txt, the issue is not resolved.

Try setting the network to "100 Mbps Half Duplex" as per TB270 page 5.
https://www.centroidcnc.com/dealersuppo ... ds/270.pdf

Page 9 explains 2 ways to view the message log.

Powering PC and HICKORY at the same time is the intended method. Powering PC first is somehow improving your odds of functional network startup. However, the problem is not fully resolved if your message log still looks like it did on the 26th.

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Mon Apr 01, 2024 10:22 am
by glbreil
Thanks eng199, I change the Speed & Duplex in the adapter to 100mpbs Half Duplex, but still not joy. It does work flawlessly if I power the computer first. Right now I just start the computer and them press the button I added to the panel to engage the Hickory Start relay as I have called it and I am good to go.

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Tue Apr 02, 2024 9:39 pm
by glbreil
Hello I have a question about the LeadShine motors and EL7-EC drives.

Over on the shopcentroid page you have the ELM2-0200 watt motor with the EL7-EC drive, but the LeadShine documentation doesn’t show anything smaller the a ELM2-0400 motor on the EL7-EC.

I just wanted to verify the 200 watt servo is compatible with the EC7-EC drive.

Thanks Gary

Re: Hardinge CHNC II+ Hickory LeadShine EL7 Retrofit

Posted: Wed Apr 03, 2024 9:07 am
by centroid467
glbreil wrote: Tue Apr 02, 2024 9:39 pm Hello I have a question about the LeadShine motors and EL7-EC drives.

Over on the shopcentroid page you have the ELM2-0200 watt motor with the EL7-EC drive, but the LeadShine documentation doesn’t show anything smaller the a ELM2-0400 motor on the EL7-EC.

I just wanted to verify the 200 watt servo is compatible with the EC7-EC drive.

Thanks Gary
Hello Gary,

The Leadshine documentation is not the most clear about this but the EL7-EC manual does state that the drives can use motors of equal or lesser power ratings. It is also mentioned on their website here
el7 400 fits smaller.PNG
and on the pages for the lower wattage motors like this 50 watt: https://www.leadshine.com/product-detai ... MA40F.html