Page 1 of 1

Please help! I fried my THC!!!

Posted: Thu Mar 28, 2024 7:20 pm
by wesgyver
Today I finally got to firing my Plasma cutter as per the instructions on page 35 of the Acorn CNC Plasma Installation manual. Unfortunately it fried my THC! :cry:

I don't know what to do next as I feel like I have everything set up as it should be. Obviously somewhere something is wrong!

My Setup:
Acorn CNC Plasma with THC (Black)
- I am retrofitting an old 5'x10' CNC Router into a 5'x10' CNC plasma.
- The machine had SureStep Motors (STP-MTRH-34097) with DM860E drivers. I realize these are not the best, but they were already on the machine.
- I have ProPoint PROCUT 80A Plasma Cutter (I already had this before purchasing the Acorn.) This plasma cutter has a 50:1 voltage divider built in.
- I am using an ohmic touch sensor. I have a ring mounted on a solenoid which lowers down when I am measuring and pulls up and out of the way during the cut. The ring does not touch the plasma torch tip, but hangs just slightly higher than the tip. I have the ohmic touch sensor connected to T IN on the THC first going through output 5 which I have set to TorchTouchDisconnect. I used output 6 set to Ohmic Enable to lower the ring when measuring.
I do not have a float switch but am using ohmic only. If it fails, I have a TorchBreakaway.

Before hitting test fire:
- Made sure all grounding was followed as per the instructions. I put a ground bus on the frame which I connected the following to: A 10' ground rod hammered into the ground behind the machine. Ground of the Plasma cutter. Ground from the electrical power connection. The water table. The gantry.
- I tested the voltage out of the voltage divider. It peaked at 3.7 volts.
- I made sure that the Positive of the Voltage divider connected to the gnd of the THC and the negative connected to the ANLV on the THC.
- I made sure the Torch breakaway operated as it should.
- I made sure that the Ohmic sensor operated correctly. When I hit torch touch button my air cylinder lowered the ring, the torch lowered until the ring touched then the ring retracted. The height was correct after the procedure.
- I ran the THC live Scope. The orange line stayed basically at zero. When the machine moved a count of approximately 10 was measured in green line (far below the 50 counts allowed.)

When I hit test fire, there was a flash then smoke coming from the THC.
I double checked the voltage from the voltage divider and confirmed the 3.7 volt max and the polarity of the connection.

What do I do next? What could have fried the THC? Any help would be GREATLY appreciated!

Re: Please help! I fried my THC!!!

Posted: Thu Mar 28, 2024 9:35 pm
by Joey
My condolences

I have not heard or can find anything about this plasma cutter when I tried searching online. Can your post links to any documentation on it?

Please post a fresh report. Reports can be created in the F7 Utility menu.

The ohmic touch off system sounds pretty slick.

Running the torch touch through an output and using the torch touch disconnect helps isolate that Tin wire so I don't think that was the issue.

I'm assuming the TX green light is not lit anymore and there is a THC encoder error in the message log of CNC12?
Hopefully not.

Does the Torch touch work anymore? Touch off cycle

The divided voltage is probably what killed or damaged the TX.
Disconnect the Divided voltage lines from the TX board.

Is there an ARC OK or OK TO MOVE signal output from the Plasma cutter?

Re: Please help! I fried my THC!!!

Posted: Thu Mar 28, 2024 11:13 pm
by wesgyver
Thanks for your response Joey,

In my emotional state after seeing the smoke... I didn't read the "Please Read Before posting questions" section. Sorry about that. I will run a report and get a few of those answers for you tomorrow hopefully. I am building this with a friend and the machine is in his shop. (It is Easter weekend so we'll see how much time I can get in the shop.)

I'll post the answers I can to start with:
The ProPoint 80A plasma cutter is sold by Princess Auto: ... 0008784480
They have a manual available on the site, though I found the manual to be lacking in information. ... l_enfr.pdf

As for the TX light, I powered down the controller as soon as I saw what had happened and then unplugged the TX board, so I don't know if there was still a light on it. There was a THC encoder error in the message log of CNC12. I'm sure it is toast as it appears damaged - a dark spot. :cry: I just unplugged the complete connector. I can plug in all but the divided voltage lines for further testing if you think that is a good idea.

My test of the output from the voltage divider was with a volt meter. I should probably bring an oscilloscope and see if it spikes more than what shows on the voltmeter.

The torch touch off does not work at the moment since I unplugged the TX board and the torch breakaway and the ohmic touch sensor both ran through the THC. Again, I could plug in all but the divided voltage lines and test that, I just was not sure if I should plug in the TX board at all since it had smoked.

As for an ARC OK or OK TO MOVE signal output from the plasma cutter, the machine only has four CNC wires. Two for Torch Trigger and two for the Voltage divider.

Obviously the machine does not work properly with the TX board unplugged. I did set the THC Installed to "No" so I could see what all still worked on the machine. The controller still has a heartbeat and I could move the machine, but received errors since some of the inputs were running through the TX board.

Re: Please help! I fried my THC!!!

Posted: Fri Mar 29, 2024 4:57 pm
by Joey
A float switch or Float device like the myohmic pro will need to be installed to touch off without a TX board.

A replacement TX board can be found here ... -tx-board/

I would suggest a Voltage divider board my the Proma voltage divider since others have had success with Chinese plasma cutters and the Proma voltage divider.

Primeweld was the Same way and needed a Proma divider board before a THC Kit was created by Centroid to adapt the Primewelds divided voltage to be compatible with the TX.

Im surprised there's no Raw Arc option so that you can use the Proma Divider Board.

Re: Please help! I fried my THC!!!

Posted: Fri Mar 29, 2024 11:31 pm
by wesgyver
Attached is a report I took today.

Re: Please help! I fried my THC!!!

Posted: Tue Apr 02, 2024 8:36 pm
by wesgyver
I got out to the shop to do some measuring. I brought along an oscilloscope to see what the output of the CNC port on the plasma cutter puts out. I had already measured this with a voltmeter and saw that it maxed at about 3.7 volts What I was not sure of is if there were voltage spikes that were not showing on my voltmeter. (Not an expensive voltmeter.)

I connected the test leads of the oscilloscope to the voltage divider output. The first test measured about 1.5 voltage divisions on the screen. (I had the scope set to 5 volts per division so that should be 7.5 volts. I did a little cutting on a scrap piece of metal and did a couple of test fires in the air. Suddenly I had smoke coming from the Scope! Was I wrong in connecting the test leads to the voltage divider output? The little wires I had soldered to my screw in connector had melted insulation and a black streak marks the location of the test lead on the scope. The scope had 4 possible division and at 5 volts per division it should have been able to measure 20 volts, double what the plasma cutter should be putting out.

Does this mean that the crazy plasma cutter is putting out WAY too much voltage, or was I just wrong in how I connected it?

Now I've burned a TX board and an oscilloscope! This is really frustrating!
Burnt 1.jpg
Burnt 2.jpg

Re: Please help! I fried my THC!!!

Posted: Tue Apr 02, 2024 9:35 pm
by Joey
Looks like the TX Board had a similar fate.

Your in uncharted waters with the ProPoint. Try and contact them for any information on there voltage divider.

Any chance of the ProPoint working with the TX will be through a divider Board that has good filters and isolation.
The Proma Voltage divider is your best shot. ... r/?lang=en