CNC 10 lathe, slowing down the rapids.

All things related to Centroid Oak, Allin1DC, MPU11 and Legacy products

Moderator: cnckeith

Post Reply
keithwhite
Posts: 16
Joined: Sat Jan 02, 2021 3:39 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: 30030

CNC 10 lathe, slowing down the rapids.

Post by keithwhite »

So I finally Got my Mori SL1 up and going , made several parts to test everything and it is doing great. The one last thing I would like to fix is when it rapids to position, It jerks the machine around pretty wildly. I can turn the feed override knob down to about 50% and it is much more manageable. Is there a parameter somewhere to turn the G0 (I think) speed down so when it rapids it would go say half that speed to make it smoother? Especially when it is entering the cut, sometimes it gouges into the part, like it is running ahead of itself and tries to overcorrect and jerk it back to where it expects it to be. I cant think this is good on the ball screws and ways and I am not sure it was designed to jerk around like that. I have tried doing things with the post processor to try and slow it down, but have not had any luck yet (Using autodesk inventor with HSM cam package)

Thank you!
cncsnw
Posts: 1971
Joined: Wed Mar 24, 2010 5:48 pm

Re: CNC 10 lathe, slowing down the rapids.

Post by cncsnw »

Yes.

F1/Setup -> F3/Config -> "137" -> F2/Machine -> F1/Jog.

Enter the desired rapid rates, in inches per minute, in the "Max Rate" column.

The software will probably suggest corresponding changes to the acceleration time in the PID menu. However, instead of following its advice, I recommend changing the Ka gains in the PID menu, in proportion to the change in Max Rate. For example, if you make the new Max Rate on an axis 60% of the old Max Rate, then change the Ka for that axis to 60% of the previous Ka.
polaraligned
Posts: 58
Joined: Mon Feb 07, 2011 8:03 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: Yes
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: No
CNC Control System Serial Number: 1030090103
Location: Montvale, NJ

Re: CNC 10 lathe, slowing down the rapids.

Post by polaraligned »

In HSM use "Leads and Transitions" menu so the machine rapids up to the point you set your "lead in", then it will G1 (or whatever) into the cut based on the type of lead-in that you set. You can independently set the feed rate of the lead-in or the lead-out and change the distance so the machine will go into the cut feedrate well before the tool gets to the part.
keithwhite
Posts: 16
Joined: Sat Jan 02, 2021 3:39 pm
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: 30030

Re: CNC 10 lathe, slowing down the rapids.

Post by keithwhite »

Changing those settings did help, it still seems jerky, but it is nowhere near as bad, I did change the lead in settings in hsm and it solved the gouging issue I mentioned. Thank you again for all the help!
cncsnw
Posts: 1971
Joined: Wed Mar 24, 2010 5:48 pm

Re: CNC 10 lathe, slowing down the rapids.

Post by cncsnw »

On the PID Configuration screen (F1/Setup -> F3/Config -> "137" -> F4/PID -> F1/PID) try increasing your acceleration times, maybe to 0.35s or 0.40s. When you do, reduce the Ka value in inverse proportion to the change in acceleration time.
Post Reply