ATRUMP E216 Mill Conversion

All things related to Centroid Oak, Allin1DC, MPU11 and Legacy products

Moderator: cnckeith

martyscncgarage
Posts: 7883
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: ATRUMP E216 Mill Conversion

Post by martyscncgarage »

cncsnw wrote: Tue Mar 09, 2021 1:04 pm Servo drive tuning can be a fairly low priority at this point, since the drives were already installed and working on this machine.

If they seem to respond to commands consistently, then move on to more important things: encoder counts, turns ratios, direction, travel limits, limit switches, etc..
Good point and great advice.
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
Jqmce
Posts: 25
Joined: Sat Feb 06, 2021 8:17 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A900979

Re: ATRUMP E216 Mill Conversion

Post by Jqmce »

You know what Marc again you are right.
Of course they were tuned for this machine that's what they are on!!
The do respond well and movement looks smooth so will leave them alone.

To be honest I feel like a bit of a moron for not realizing that myself.

Thank you.
Jqmce
Posts: 25
Joined: Sat Feb 06, 2021 8:17 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A900979

Re: ATRUMP E216 Mill Conversion

Post by Jqmce »

Hey guys,
So things are looing good but have just hit another road bump.
Configuration of the Axis to move correct distance is complete. To my surprise i could get it to within 0.001mm repeatable so that's great.

The issue I'm having now is Homing the machine. 6.6 in install manual step 5.
I verified all home switches and they all work.
When hitting Alt-S or the start button i get the following fault.
"913 could not open file test.cnc"

I had it briefly a couple of days ago but now it is every time i try to start.

Did a search on here for 913 but it seems it's a fairly generic fault that can mean a lot of things.
I'm assuming it should be finding Cncm.Hom file. but my real concern is why did it change if it was working?

Report below. Thanks
Jules
cncsnw
Posts: 1971
Joined: Wed Mar 24, 2010 5:48 pm

Re: ATRUMP E216 Mill Conversion

Post by cncsnw »

If it is trying to open and run "test.cnc" when you press Cycle Start, that is probably because:
1) CNC12 thinks that home has already been set, and
2) The currently-loaded job name is "test.cnc".
cncsnw
Posts: 1971
Joined: Wed Mar 24, 2010 5:48 pm

Re: ATRUMP E216 Mill Conversion

Post by cncsnw »

If you have already set home (perhaps at an arbitrary position), and you now want to go back and run the automatic homing routine, you need to do one of several things:
1) Shut down, power off (specifically, power off the Oak control unit), and restart
2) Load c:\cncm\cncm.hom as if it were a normal CNC job, and then run it.
(note that cncm.hom might not exist yet, if you have never done an auto home on this control)
3) Exit CNC12, delete the cncm.job.xml file, and then restart CNC12.

Generally, (1) is the simplest and most straightforward.
Jqmce
Posts: 25
Joined: Sat Feb 06, 2021 8:17 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A900979

Re: ATRUMP E216 Mill Conversion

Post by Jqmce »

Thanks Marc,
Shut down worked.
Homing setup worked a treat.
Backlash comp worked really well with instructions and 0.002 indicator. XY Lash on machine is @ 0.021mm (0.82 thou) so not too bad.... ish.

Spindle is not running yet. It initiates without fault and shows RUN, REV, etc but not spinning. I have to re-check all wiring first before double checking TB183 settings and then go from there.
I wired it to Print S14699 as this is the absolute closest I could find. (Schematics are VFD-VE where as my drive is VFD-V so if anyone has prints showing VFD-V in Atrump E216 and could take a pic it would be appreciated)

I'll take some pics of the electrical cabinet next week. It's still a bit of a dogs breakfast in this testing stage.

Cheers,
Jules
Jqmce
Posts: 25
Joined: Sat Feb 06, 2021 8:17 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A900979

Re: ATRUMP E216 Mill Conversion

Post by Jqmce »

Sunday update and questions.
Spindle is now working as it should.
Setup the soft limits and all went well.
M19 Spindle orient is working and I tweaked the position ever so slightly.
Double checked carousel in and out sensors and they are good.
Checked output for carousel CL, CCl and it rotates and positions.
Checked tool release and air blow with MDI and all ok.

What I could not test was carousel out and in. I can’t force it out through MDI. M80, M81. I ensured the spindle orient was complete first. Still nothing. I never get voltage from the outputs on 1616 extension board. I tried whilst holding Aux 12 and not.

The setup info for the ATC is a bit spotty. Is there a procedure or document I should follow when setting this up?

I have not completed systems test yet as I have not checked all the ATC functions.

Overall a good couple of hours spent today. I’m getting close real close.

Thanks
Jules
martyscncgarage
Posts: 7883
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: ATRUMP E216 Mill Conversion

Post by martyscncgarage »

Jqmce wrote: Sun Mar 14, 2021 4:47 pm Sunday update and questions.
Spindle is now working as it should.
Setup the soft limits and all went well.
M19 Spindle orient is working and I tweaked the position ever so slightly.
Double checked carousel in and out sensors and they are good.
Checked output for carousel CL, CCl and it rotates and positions.
Checked tool release and air blow with MDI and all ok.

What I could not test was carousel out and in. I can’t force it out through MDI. M80, M81. I ensured the spindle orient was complete first. Still nothing. I never get voltage from the outputs on 1616 extension board. I tried whilst holding Aux 12 and not.

The setup info for the ATC is a bit spotty. Is there a procedure or document I should follow when setting this up?

I have not completed systems test yet as I have not checked all the ATC functions.

Overall a good couple of hours spent today. I’m getting close real close.

Thanks
Jules
Post a fresh report Jules....
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
cncsnw
Posts: 1971
Joined: Wed Mar 24, 2010 5:48 pm

Re: ATRUMP E216 Mill Conversion

Post by cncsnw »

The PLC program you are using appears to use Aux14 (not Aux12) as the "ATC Override" key.

Aux14 is the blank blue key, right-most in the coolant row.
Jqmce
Posts: 25
Joined: Sat Feb 06, 2021 8:17 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A900979

Re: ATRUMP E216 Mill Conversion

Post by Jqmce »

Morning Guys,
Came in early to run some tests.
This is what I know.... Or don't know more to the point.

I initialized the tool library F6 and setup two fake tools.
I have no idea how to activate AUX12 or AUX14. (I'm not using a touch screen yet so was holding Aux button whist hitting start button on MPG)
I tried every combination I could think of but no movement with M80, M81.
triple checked carousel out / in solenoid wiring and carousel out / in sensor inputs and it all looks correct.
*Stupid Question. (I'm assuming carousel IN is home and OUT is below spindle head for tool change is this correct?)
Verified M15 unclamp works.
Verified M16 clamp works. (Please note this machine only has one solenoid for tool unclamp / clamp. (5/2 valve)


So I tried running the ATC tool change just to see what would happen. figured worst case scenario is I get more data.
This is where things get interesting.
With my hand firmly on the E-stop ready to pounce.
It initiates the tool change in the following order....
-Sets z position. (Note i have not set up actual position yet so Z actually goes home. Left it like this to prevent any potential damage when testing
as spindle is out of the way)
- Orients spindle correctly.
-Unclamps tool. (This is weird as the carousel is not out yet!)
-Tool clamps.
-Carousel comes out and it sees carousel out sensor on input-15 (expansion 1616)
-At this point it says "313 waiting for dwell time" and nothing else happens. No error.

To rectify this the program must be stopped, estop pushed, carousel returned to "in" position (home) via solenoid override and reset.

So things are moving (Which is good) but not in the correct sequence or I have not set something up correctly.
The Schematics Centroid provided for this PLC program are S14798.

Report is below. (Thanks for the reminder Marty) I'm not sure where to go from here.

Thanks
Jules
Post Reply