Tool Check Spindle Dwell

All things related to Centroid Oak, Allin1DC, MPU11 and Legacy products

Moderator: cnckeith

Post Reply
mrichards
Posts: 34
Joined: Thu Feb 28, 2019 12:05 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: Yes
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: none

Tool Check Spindle Dwell

Post by mrichards »

I currently have a dwell time programmed into my M3 macro to allow 5 seconds for the spindle to spool up, which works as expected except when resuming from a tool check.
When I resume, motion starts immediately after the spindle is energized. If I forget to crank down the feedrate override before I hit cycle start, things get ugly. I'm aware of the VFD "at speed" hardwire option (though I'm not sure if that would work any better in this situation) however that's not physically possible for my install at the moment.
Doesn't resume run through the code up the tool check point including executing the M3 command? Why no dwell?

Thanks.
Attachments
report_0008DC111213-0916201004_2020-12-07_16-00-46.zip
(843.13 KiB) Downloaded 19 times
------------
Mark
cncsnw
Posts: 1892
Joined: Wed Mar 24, 2010 5:48 pm

Re: Tool Check Spindle Dwell

Post by cncsnw »

Your M3 macro says:

Code: Select all

;...
IF #4202 || #4201 THEN GOTO 200
M95 /2
M94 /1
IF #61058 THEN GOTO 200 ;skip the check if AutoSpindle is on
G4 P.1
#140 = 1.5 
N100
IF !#61058 THEN M225 #140 "Please Select Auto Spindle To Continue!" ;61058 = JPO2/SpindleAutoManualLED
G4 P4
IF !#61058 THEN GOTO 100
N200
I am guessing that when Run -> Resume executes the M3, it still has the search-mode variable #4202 set. Your M3 logic skips over all of its actions when that variable is set. Try at least putting your dwell time after N200.

That said, I don't even see how your dwell time would happen in normal operation, if you have already selected Auto Spindle mode.
Post Reply