Page 3 of 7

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Tue Sep 14, 2021 8:12 pm
by BillB
Here are a couple screenshots of those log pages, just a couple random pages, looks like lots of errors but I’m not sure what I’m looking for exactly.

When I set up PC I updated everything btw

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Tue Sep 14, 2021 8:15 pm
by BillB
Do you want me to post the entire report to the thread? Can I upload it somehow?

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Tue Sep 14, 2021 9:22 pm
by martyscncgarage
Those are PC/MPU resends. They need to be corrected. We need to determine if it's the PC or EMI noise.

On Acorn, unplug everything except power from the provided power supply and the provided Ethernet cable.
Start CNC 12 and leave it run. Check your error logs

It would be good if you can set Acorn to DB25 bench test for this test. Make sure you are set up for simple home. In CNC12, press cycle start to set home. DRO's should be zeroed.
Then load any program and press cycle start to run it
Afterwards, look at your error logs for any PC/MPU resends.

Did you update the drivers on that PC?

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Tue Sep 14, 2021 9:30 pm
by martyscncgarage
I would appreciate if you would upload your report file.
You click on FULL EDITOR & PREVIEW button.
Then click on the Attachments button under the message box where you type your message Point to the file on your computer.

You need to learn to do this as a fresh report is required when asking for support on this forum.
Marty

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Wed Sep 15, 2021 12:57 am
by BillB
I did update drivers when I set up the computer as per CNC PC set up steps. Your video.

You asked me to unplug everything except Ethernet cable and power supply but then you said to make sure I have simple home set in the wizard whitch I did then wrote to Acorn. But now because the limit switches are unplugged I get this error. I can not 0 the DROs out because home switch is tripped cuz it’s unplugged. Should I delete home all from inputs?

How to proceed to get report done?

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Wed Sep 15, 2021 9:29 am
by martyscncgarage
You need to load a DRIVE type. Benchtest DB25.

I have mentioned several times how to create the report.
From the main CNC12 Screen
Press F7 Utility
Then from the Utility Screen press F7 Create report.

Maybe the video in this post will help:
viewtopic.php?f=63&t=943

You need to figure out the PC/MPU resends. Those are ethernet communications errors between the PC and Acorn

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Wed Sep 15, 2021 9:50 pm
by BillB
Marty Here is my report.

I hope this is good to get what we need to know. I had to turn off Home all, because now when I hit cycle start the 1st axis starts to move and keeps moving as it is searching to hit a limit switch. It keeps going on forever until I physically hit one of the switches. after I hit this switch the DRS will not zero out. I changed settings for max travels and it keeps going on beyond the set limit? SO I just turned it off.

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Wed Sep 15, 2021 9:52 pm
by BillB
I was able to get the report from Sherline so gonna load it up and see what happens.

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Thu Sep 16, 2021 12:39 am
by BillB
Good news, got motors turning with Sherlines drive configuration.

BUT can not get machine homed and DROs zeroed out. When hitting cycle start to home I’m getting “home switch tripped!!! please clear before homing. Press cycle cancel to end homing.

John has homing “1st 2nd 3rd Axis home ok” in inputs

As said before limit/home switches are working when pressed.

Is there something wrong with my wiring for the switches, It's wired as per S14954 but I've added the terminal blocks. Cleaned up the wires so you could more clearly trace them.

Re: My Sherline chucker lathe & 5400 mill with Acorn control build

Posted: Thu Sep 16, 2021 12:42 am
by martyscncgarage
Please Post a NEW fresh report.
How do you have your home switches configured? Are they on series and you are using HomeAll?