Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

All things related to the Centroid Acorn CNC Controller

Moderator: cnckeith

martyscncgarage
Posts: 8228
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by martyscncgarage »

Richards wrote: Tue May 04, 2021 8:37 am Page 4 of the 1616 user guide shows that the IP address that you listed is not valid. Please verify that the address you are using is the address listed in the 1616 documentation. The address on my computer is 10.158.41.1. The computer's subnet mask is set to 255.255.255.0, which means that the computer can ONLY communicate with other devices in the range of 10.168.41.2 to 10.168.41.254. If I remember correctly, the Acorn's default address is 10.168.41.2 and the A0 address on the 1616 board is 10.168.41.3.

Do you have a photo of how you've connected your ethernet switch between your computer, the Acorn and the 1616 board? Also does the switch show both activity and connection LEDs for all three devices?



1616.JPG
Mike, his first post seems to indicate ether1616 is set to A0 and he is able to ping that address.
You did bring something up that made me think.

He should go in and verify his ethernet adapter settings.
Follow this video carefully to verify your ethernet adapter is setup properly.
viewtopic.php?f=61&t=1451
Post a screen shot of the ethernet adapter settings.

Also, I second Mike's request, please post a picture of your Acorn, Ethernet Switch and Ether1616 setup. There should be only 3 connections on the switch, PC, Acorn and Ether1616.

Marty
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
Richards
Posts: 511
Joined: Sun Sep 16, 2018 9:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: none
Location: South Jordan, UT

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Richards »

Marty, I noticed that he wrote A0, but he listed the IP address as 10.168.1.43 (which I assume was probably a typo because I know of no way to set the 1616 to that address; however, I included the note about IP addresses just in case it is possible to set the 1616's IP address to another subnet).

Here's what I checked on my test bench:

1. The computer's IP address is 10.168.41.1 with a subnet of 255.255.255.0. No gateway. (Packets don't leave the 10.168.41.0/24 subnet, so no gateway is required.)

2. The Acorn responds to pings at 10.168.41.2

3. The 1616 responds to pings at 10.168.41.3

Only those three devices are connected to the switch. Each device has a shielded CAT-6 cable going from the device to the switch. The three switch ports show link and activity. The LEDs on a Level-1 switch usually give sufficient information to show that the devices are physically connected and that packets are being sent and received to/from each device.
-Mike Richards
Arthur
Posts: 33
Joined: Sat May 16, 2020 12:09 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A81087C2F400-0530192077

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Arthur »

Richards wrote: Tue May 04, 2021 8:37 am Page 4 of the 1616 user guide shows that the IP address that you listed is not valid. Please verify that the address you are using is the address listed in the 1616 documentation. The address on my computer is 10.158.41.1. The computer's subnet mask is set to 255.255.255.0, which means that the computer can ONLY communicate with other devices in the range of 10.168.41.2 to 10.168.41.254. If I remember correctly, the Acorn's default address is 10.168.41.2 and the A0 address on the 1616 board is 10.168.41.3.

Do you have a photo of how you've connected your ethernet switch between your computer, the Acorn and the 1616 board? Also does the switch show both activity and connection LEDs for all three devices?



1616.JPG
My original post indicates the right IP address 10.168.1.43 for the E1616 board. "169" in my late response was typo, my apologies.

The copy of Acorn controller I received, came with the manual stating that IP address of NIC card of the PC running CNC12 should be set to 10.168.1.41 Subnet Mask set to 255.255.255.0 and E1616 board should be set to default A0 = 10.168.1.43 I just posted a cutout screen shot from page 4 of the manual. So my Acorn controller, E1616 Expansion Board and PC, are in the same subnet pool. Unfortunately, it seems I missed to interpret reading of seven segment LED, which I have to look into.
martyscncgarage
Posts: 8228
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by martyscncgarage »

Arthur, please take the time to check your PC's ethernet adapter settings per the video....
Marty
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
Arthur
Posts: 33
Joined: Sat May 16, 2020 12:09 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A81087C2F400-0530192077

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Arthur »

Richards wrote: Tue May 04, 2021 11:22 am Marty, I noticed that he wrote A0, but he listed the IP address as 10.168.1.43 (which I assume was probably a typo because I know of no way to set the 1616 to that address; however, I included the note about IP addresses just in case it is possible to set the 1616's IP address to another subnet).

Here's what I checked on my test bench:

1. The computer's IP address is 10.168.41.1 with a subnet of 255.255.255.0. No gateway. (Packets don't leave the 10.168.41.0/24 subnet, so no gateway is required.)

2. The Acorn responds to pings at 10.168.41.2

3. The 1616 responds to pings at 10.168.41.3

Only those three devices are connected to the switch. Each device has a shielded CAT-6 cable going from the device to the switch. The three switch ports show link and activity. The LEDs on a Level-1 switch usually give sufficient information to show that the devices are physically connected and that packets are being sent and received to/from each device.
All three devices: PC, Acorn and E1616 are connected using supplied shielded ethernet cables and the switch. Switch indicates active green link LEDs on all three ports, but only PC and Acorn ports are showing activity (pocket exchange, green light LEDs blinking) The port designated for E1616 has a steady green light.
Arthur
Posts: 33
Joined: Sat May 16, 2020 12:09 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A81087C2F400-0530192077

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Arthur »

martyscncgarage wrote: Tue May 04, 2021 1:01 pm Arthur, please take the time to check your PC's ethernet adapter settings per the video....
Marty
I did Marty,
NIC Card Settings.png
Arthur
Posts: 33
Joined: Sat May 16, 2020 12:09 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A81087C2F400-0530192077

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Arthur »

martyscncgarage wrote: Tue May 04, 2021 10:11 am
Richards wrote: Tue May 04, 2021 8:37 am Page 4 of the 1616 user guide shows that the IP address that you listed is not valid. Please verify that the address you are using is the address listed in the 1616 documentation. The address on my computer is 10.158.41.1. The computer's subnet mask is set to 255.255.255.0, which means that the computer can ONLY communicate with other devices in the range of 10.168.41.2 to 10.168.41.254. If I remember correctly, the Acorn's default address is 10.168.41.2 and the A0 address on the 1616 board is 10.168.41.3.

Do you have a photo of how you've connected your ethernet switch between your computer, the Acorn and the 1616 board? Also does the switch show both activity and connection LEDs for all three devices?



1616.JPG
Mike, his first post seems to indicate ether1616 is set to A0 and he is able to ping that address.
You did bring something up that made me think.

He should go in and verify his ethernet adapter settings.
Follow this video carefully to verify your ethernet adapter is setup properly.
viewtopic.php?f=61&t=1451
Post a screen shot of the ethernet adapter settings.

Also, I second Mike's request, please post a picture of your Acorn, Ethernet Switch and Ether1616 setup. There should be only 3 connections on the switch, PC, Acorn and Ether1616.

Marty
I am guessing 10.158.1.41 is a typo and It should be 10.168.1.41 right?
martyscncgarage
Posts: 8228
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by martyscncgarage »

What make model switch do you have and have you tried swapping the port with Acorn....
Never run into this before...
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
Arthur
Posts: 33
Joined: Sat May 16, 2020 12:09 am
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: A81087C2F400-0530192077

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by Arthur »

RogDC wrote: Mon May 03, 2021 11:48 pm
Arthur wrote: Mon May 03, 2021 9:39 pm
I just added a photo to this topic showing the status of LED’s on E1616 board

I received no error code or messages of any kind, but I checked the Ethernet connectivity with E1616 board by issuing ping command to IP 10.169.1.43 address in Command Line of the PC running CNC12.
Image

The segment display in the red circle will provide a status indication or error code. I'm not able to tell from the angle of the photo what the display is indicating.

Pinging the IP address of the Ether1616 from the computer does test connectivity from the PC to the Ether1616,however does not test connectivity from the Ether1616 to the Acorn.

If there is no connectivity to the Acorn from the Ether1616, the segment display will indicate a '2'.
I just went through the entire manual again and couldn't find a single word about seven segment display readings...
martyscncgarage
Posts: 8228
Joined: Tue Mar 28, 2017 12:01 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: Yes
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC12: Yes
CNC11: Yes
CPU10 or CPU7: Yes
CNC Control System Serial Number: none
Location: Mesa, AZ

Re: Purchased a new Ether1616 board but it is not autodetecting in CNC12 Wizard

Post by martyscncgarage »

Page 58:
https://www.centroidcnc.com/centroid_di ... _guide.pdf

Read the top of page 54 to set a static IP address or set the jumpers to DHCP.
Reminder, for support please follow this post: viewtopic.php?f=20&t=383
We can't "SEE" what you see...
Mesa, AZ
Post Reply