VCP error, CNC 12 V4.50 ?

All things related to the Centroid Acorn CNC Controller

Moderator: cnckeith

Post Reply
Posts: 11
Joined: Fri May 25, 2018 2:57 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
CNC11: No
CPU10 or CPU7: No
CNC Control System Serial Number: 38D2694D8E8B-0320180746

VCP error, CNC 12 V4.50 ?

Post by tfhess »

I've been having some trouble with what appears to be a VCP error. I am setting up a slantbed lathe with ATC and upon Acorn startup, everything loads correctly, I can home correctly and the MDI works on Acorn CNC 12 V4.50. The VCP is mostly working on all buttons except when Z- is pushed it results in the ATC head rotating (A axis). I have re downloaded V4.5 and installed it with the same result. I have uninstalled 4.5 and reloaded it with the same result. I cannot find where the error is. (And yes, it is wired correctly - V4.20 used to work and MDI works under 4.50).

I am running a Leadshine knockoff system (HBS860H) with hybrid servos on 3 axes wired similar to the Standard Connections Acorn schematic.

A couple of pics showing the ATC head (partially disassembled to allow it to turn when VCP kluges) and controls are attached.
(637.93 KiB) Downloaded 84 times
Post Reply