dc servos Axis jumping when moving <<Resolved, tune motors.>>

_______________________________________________________














LOGIN below to POST your questions and comments on AjaxCNC products.

Moderator: cnckeith

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

dc servos Axis jumping when moving <<Resolved, tune motors.>>

Post by toolmaker101 » Tue Jan 02, 2018 6:21 pm

I just had new control installed on my mill. Right after the install the z would only freeze and jump in rapid moves now when I move the Z axis it freezes and jumps so i hit the E stop. It will only move in slow with the feed turned down all the way. I can gradually turn the feed up wile it is moving to get it to go faster but if I stop and try to move at the faster rate it will freeze up add go to shacking the hole machine.
Thank you in advance for your help,

frijoli
Posts: 389
Joined: Tue Sep 12, 2017 10:03 pm
Acorn CNC Controller: Yes
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: No
CPU10 or CPU7: No
System Serial Number: none yet
Location: Outside Winston-Salem, NC

Re: Axis jumping when moving

Post by frijoli » Tue Jan 02, 2018 8:44 pm

What control board do you have., What motors and drives?

Clay
Outside Winston-Salem, NC

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 12:25 pm

cnc11 mpu11 Qudra drive, X & Z are SEM motors Y is an new Centroid motor installed last year.

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 1:12 pm

Hear is a currant report. also the control # is 102978
Thank you.
Attachments
report_1013171367_2018-01-03_11-06-32.zip
(1.15 MiB) Downloaded 11 times

cncsnw
Posts: 350
Joined: Wed Mar 24, 2010 5:48 pm

Re: Axis jumping when moving

Post by cncsnw » Wed Jan 03, 2018 4:27 pm

Do you think the issue might be related to the many "407 ... limit tripped" conditions reported in your error message log? Or to the couple "9030 SPINDLE FAULT" messages?

Use the Alt-i PLC Diagnostic display to see whether all six limit inputs (INP1 - INP6) are green, and stay green except when the limit switches are actually tripped. Also check whether INP14 is green, and stays green except when your spindle drive is actually in a fault condition.

Do the X and Y axes move smoothly and under control?

My guess is that you have a faulty (or maybe just loose) position encoder on the Z axis motor.

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 5:04 pm

Thank you
The many 407 is me trying to get the machine limits set using the Test in setup config. When I turn on the mill I get the warning the machine is not setup message contact your dealer! I am using the "Tech Bulletins 289 Software Travel Limits" to try set them up. But scene the z messes up I cant complete the test.This will be an issue fore another day.

The 9030 has been going on for a wile it goes away with an Estop I Hoped to have that looked into when I had the new control put on but that did not happen.This will be an issue fore another day.

The Z axis issue came up right after the new control was put on This is an issue that keeps me from using the mill.
I will swap the encoder with a new one. and let you know if it helps.

Thank you

cncsnw
Posts: 350
Joined: Wed Mar 24, 2010 5:48 pm

Re: Axis jumping when moving

Post by cncsnw » Wed Jan 03, 2018 5:11 pm

Before buying a new encoder, you might try to expand upon "freeze up", "jump", and "shacking the hole machine" for us.

Does the encoder position for the Z axis (as shown under "Abs Pos" on the PID Configuration screen) count consistently when you turn the Z axis motor by hand?

Does the '*' next to the Z in the left-most column of that display, indicating the location of the encoder index pulse, always appear at the same motor shaft position, even after a stall episode?

What kind of machine is this?

Does the Z servo motor have a holding brake? If so, what voltage does the holding brake use for release, and where does that voltage come from?

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 6:21 pm

I have 1 used old style encoder like in the pitcher and 2 brand new, new style ones on the shelf.
The machine is a Revolution 3 axis bed mill.
I will try to get you the info on the encoder asap.
Attachments
20180103_154517.jpg

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 6:23 pm

That is my old y axis motor on the table I stooled the encoder off of it just a wile ago.

toolmaker101
Posts: 16
Joined: Tue Dec 26, 2017 11:16 am
Acorn CNC Controller: No
Allin1DC CNC Controller: No
Oak CNC controller: No
MPU11 & GPIO4D -w/ 3rd Party Drives: No
DC3IOB: No
CNC11: Yes
CPU10 or CPU7: Yes
System Serial Number: 102978, 8121, REV233

Re: Axis jumping when moving

Post by toolmaker101 » Wed Jan 03, 2018 7:22 pm

cncsnw wrote:
Wed Jan 03, 2018 5:11 pm
Before buying a new encoder, you might try to expand upon "freeze up", "jump", and "shacking the hole machine" for us.

Does the encoder position for the Z axis (as shown under "Abs Pos" on the PID Configuration screen) count consistently when you turn the Z axis motor by hand?

Does the '*' next to the Z in the left-most column of that display, indicating the location of the encoder index pulse, always appear at the same motor shaft position, even after a stall episode?

What kind of machine is this?

Does the Z servo motor have a holding brake? If so, what voltage does the holding brake use for release, and where does that voltage come from?
Explaining freezing jumping and shaking. The attached pitcher is right after I pushed the Z down arrow the head goes down a small amount then it stops going down "freezing up" and the head starts going up and down very little I call this jumping. I gets so sever it shakes the hole mill. It will not stop until I hit the estop.

Does the encoder position for the Z axis (as shown under "Abs Pos" on the PID Configuration screen) count consistently when you turn the Z axis motor by hand? YES even after it freezes and jumps.

Does the Z servo motor have a holding brake? If so, what voltage does the holding brake use for release, and where does that voltage come from? The wiring diagram shows it as a option @ 24 VDC
I have the cap off of the Z motor and it has 2 extra wires that my old y motor dose not have. must be that brake???I will open the electrical cabinet and see were they go!
I will have to get back to you as I am typing this up on the mill console.
Attachments
20180103_164930.jpg

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest